Installing beta from nupkg download

Mar 14, 2012 at 5:21 PM

I've downloaded and extracted the latest  (Version 1.0.14.1-beta.nupkg files from this site, and placed them in my local folder.  I have configured package manager to point to this folder. I can see other packages but not these. I isolated these files into their own folder, configured package manager to point to that folder, and still nothing.  Here are PM Console results:

PM> get-package -updates
No package updates are available from the current package source.
PM> get-package -listavailable
PM> Install-Package TelerikMvcGridCustomBindingHelper.NHibernate
Install-Package : Unable to find package 'TelerikMvcGridCustomBindingHelper.NHibernate'.
At line:1 char:16
+ Install-Package <<<<  TelerikMvcGridCustomBindingHelper.NHibernate
    + CategoryInfo          : NotSpecified: (:) [Install-Package], InvalidOperationException
    + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand
 
PM> 

Coordinator
Mar 14, 2012 at 6:23 PM

TelerikMvcGridCustomBindingHelper.NHibernate is a prerelease version, to install it you need the following command:

PM> Install-Package TelerikMvcGridCustomBindingHelper.NHibernate -Pre

Notice the "-Pre" switch.

These others also works;

 PM> get-package -updates -pre

PM> get-package -listavailable -pre


Coordinator
Mar 14, 2012 at 6:54 PM
Edited Mar 14, 2012 at 6:56 PM

More help installing and upgrading prerelease packages here:

http://docs.nuget.org/docs/reference/versioning#Installing_Prerelease_Packages

Mar 14, 2012 at 9:18 PM
Edited Mar 14, 2012 at 9:30 PM

Ok, I installed but now I'm getting an error during build (I have package restore on build turned on)

 

Error	2	Version string specified for package reference 'TelerikMvcGridCustomBindingHelper' is invalid.	MYPROJECT.MVC

the entries in package.config are

  <package id="TelerikMvcGridCustomBindingHelper" version="1.0.14.1-beta" />
  <package id="TelerikMvcGridCustomBindingHelper.NHibernate" version="1.0.14.1-beta" />

Coordinator
Mar 14, 2012 at 11:52 PM

I'm not sure, but I think that the package restoration does not support prerelease versions, anyway you said you had already installed, so I do not understand why you are seeing this error.

If you really need this feature I can send the packages to you without the "beta" flag.

Mar 15, 2012 at 12:55 AM

No need.  I commented out the lines in package.config file and was able to compile.  This looks like a package restore bug to me, since it doesn't gracefully support pre-release packages.

Coordinator
Mar 15, 2012 at 1:03 AM

Nice! And how are the tests with booleans values and Oracle paging bugs, respectively  Issue #3 and Issue #4?

Mar 15, 2012 at 1:13 AM

Paging bug is still there since I provided you with wrong code, but I updated the issue with the (hopefully correct) change that needs to be made.  Good thing this was a beta build :)

I have switched to mapping flag to boolean with NHibernate YesNo mapping, which I think is a very good place to do that sort of thing.  Do you want me to set up the mapping through AutoMapper and try one of your suggestions?

Mar 15, 2012 at 9:15 PM

For those interested, the build error I was getting was due to an older version of nuget.exe being used in my solution.  Once I updated nuget.exe to latest version the project compiled with no package.config comment-out modifications.  See details on this issue here.

Coordinator
Mar 16, 2012 at 12:48 AM

Hello Alex, I made the changes you asked me and I would like you to test itmore detailsin my comment on the issue #4.

About the booleans, yes please do some tests and let me know if everything went wellThank you.